Crystal Reports 2008

OFT - 700
Today’s road map

• Why use Crystal Reports
• Definition of a report and its components
• How to use the Standard Report Creation Wizard: query the database and organize the data
• How to format a report
• How to add new fields to a report
• How to modify the records selection
• Boolean logic (and/or)
• How to add summaries
• How to export a dataset to another application
• How to create mailing labels
Why use Crystal Reports?

• Crystal Reports is the recommended software at McGill University to access the Banner Data Warehouse
  – Financial Services provide reports that you can modify with Crystal Reports
    http://www.mcgill.ca/financialservices/reporting/monthendrep

• Used for reports that do not exist

Where to check:
• Minerva > Reports
• Financial Services web site (see link above)
• Your department may have existing reports that you can modify
Why use Crystal Reports

For Enrolment Services, go to
http://www.mcgill.ca/es/dwh/contact

• To get help with a report
• To request a report
Why use Crystal Reports?

- Allows you to create your own reports by:
  - **querying** a database to get your data
  - **organizing** the data
  - **displaying** and **printing** the data in a format of your choice
  - **exporting** the data to another application (e.g. Excel)
  - **saving** the report template and reuse it at will
What is a report?

• A report is a formatted and organized presentation of data derived from a database query

• Examples of reports:
  • Class list
  • Mailing labels
  • Statistical reports
  • Financial statements
What is a report?

Some of the elements of a report

- Title
- Header
- Records
- Groups
- Subtotals
- Total
- Footer
How is the data stored?

- In a database, the data is stored in multiple tables
- A table is made of fields (columns) and records (rows)
- A view is a collection of fields selected from different tables to make the reporting easy

<table>
<thead>
<tr>
<th>ID</th>
<th>Last name</th>
<th>First name</th>
<th>Dept.</th>
<th>City</th>
</tr>
</thead>
<tbody>
<tr>
<td>260154874</td>
<td>Roberts</td>
<td>Julia</td>
<td>M-Eng</td>
<td>Quebec</td>
</tr>
<tr>
<td>150487958</td>
<td>Martin</td>
<td>Steve</td>
<td>Info Sc.</td>
<td>Paris</td>
</tr>
<tr>
<td>150143683</td>
<td>Smith</td>
<td>Bob</td>
<td>Medicine</td>
<td>Quebec</td>
</tr>
</tbody>
</table>
Creating a report

Students in Quebec City studying Medicine

<table>
<thead>
<tr>
<th>ID</th>
<th>Last name</th>
<th>First name</th>
<th>Dept.</th>
<th>Street</th>
<th>City</th>
</tr>
</thead>
<tbody>
<tr>
<td>260154874</td>
<td>Roberts</td>
<td>Julia</td>
<td>M-Eng</td>
<td>123 Cedar</td>
<td>Quebec</td>
</tr>
<tr>
<td>150487958</td>
<td>Martin</td>
<td>Steve</td>
<td>Info Sc.</td>
<td>456 Pine</td>
<td>Paris</td>
</tr>
<tr>
<td>150143683</td>
<td>Smith</td>
<td>Bob</td>
<td>Medicine</td>
<td>789 Maple</td>
<td>Quebec</td>
</tr>
<tr>
<td>260879614</td>
<td>Pitt</td>
<td>Brad</td>
<td>Medicine</td>
<td>1357 Oak</td>
<td>Quebec</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Last name</th>
<th>First name</th>
<th>Street</th>
<th>City</th>
</tr>
</thead>
<tbody>
<tr>
<td>Smith</td>
<td>Bob</td>
<td>789 Maple</td>
<td>Quebec</td>
</tr>
<tr>
<td>Pitt</td>
<td>Brad</td>
<td>1357 Oak</td>
<td>Quebec</td>
</tr>
</tbody>
</table>
Getting Started

Crystal Reports 2008 Start Page

- Toolbar
- Start Page
- Wizards
- Open Recent Reports
- Getting Started Videos

START A NEW REPORT
- Blank report wizard
- Cross-tab report wizard
- Mailing label report wizard
- OLAP Cube Report Wizard

MY RECENT REPORTS
- World Sales Reportcript
- Open File

FREE PRODUCT ADD-ONS
- Sample Reports + Databases
- Runtime Packages
- Crystal Reports for Eclipse
- .NET SDK documentation
- JAVA SDK documentation
- Crystal Reports Viewer 2008
- Data Direct ODBC Drivers
- ESRI GIS Map Viewer
- Free Online Report-Sharing

GETTING STARTED VIDEOS
Check out the new SAP Crystal Reports Introductory Series videos on YouTube.

SUPPORT FOR SAP CRYSTAL REPORTS
Get the most from SAP support resources, articles, and forums; and read about technical support for volume products.

CRYSTAL REPORTS SERVER
2008 FREE TRIAL
Manage, share, and deliver critical business information with a single server solution.

SAVE 20% ON SAP CRYSTAL REPORTS
AND MORE
Learn more

RECENT NEWS
- SAP Opens New Fast Lanes to Help Companies Run Better
- SAP Announces Sponsorship of Rising Canadian Tennis Star Milos Raonic

SEARCH SAP
Getting Started

To Create a new report do 1 of the following:

• Click on **Report Wizard** from the **Start Page**
• Click on the **New** icon
• Click on **File > New > Standard Report...**
Standard Report Creation Wizard

The Wizard guides you through the steps to create a report:

• Connect to the Database
• Select the view / table
• Choose the fields to display in the report
• Group the records
• Add summaries like totals to the report
• Select a subset of records for the report
• Choose a template
To Connect to the database

1. Click on the '+ ' next to Create New Connection

2. Click on the '+ ' next to the location of your database (Oracle server for Banner)

First step: establish a connection to the database
The Standard Report Creation Wizard

To log into the Banner data warehouse

1. Service: banrep.mcgill.ca
2. Enter your **Banner User ID** and **Password**
3. Click on **Finish**
Click ‘+’ in front of **DWH** to view the tables/views
Views: Groups of fields extracted from multiple tables.

To select a view:

- Select the view name and click on the Arrow button  
- Click and drag the view to the right panel  
- Double-click the view name in the left panel

The selected view name will be displayed in the right side column as the data source for the report

Click Next button
Fields window: select fields from the view to display on your report

To select the fields:

- Click the field name and click on the Arrow button  
  Click and drag the field to the right panel  
  Double-click the field name in the left panel
- Hold the Ctrl key to select many fields
- Click Find Field... to search for a field
- Click Next button
There is a difference between selecting and displaying

- Displaying means showing the fields you wish to see on your report

- Selecting means extracting from the database the records needed for your report
  - For example, you can select all the clients from Montreal but not display the city on the report.
  - Conversely, I can display the city without making a selection. (Display all records)

<table>
<thead>
<tr>
<th>ID</th>
<th>Last name</th>
<th>First name</th>
<th>Dept.</th>
</tr>
</thead>
<tbody>
<tr>
<td>260569871</td>
<td>Knight</td>
<td>Julia</td>
<td>M-Eng</td>
</tr>
<tr>
<td>260598741</td>
<td>Rosenberg</td>
<td>Steve</td>
<td>Info Sc.</td>
</tr>
<tr>
<td>260378452</td>
<td>Shepard</td>
<td>Bob</td>
<td>Medicine</td>
</tr>
<tr>
<td>260841235</td>
<td>Assaf</td>
<td>Brad</td>
<td>Medicine</td>
</tr>
</tbody>
</table>
Data grouped and summarized

<table>
<thead>
<tr>
<th>Date</th>
<th>Customer Name</th>
<th>Last Year's Sales</th>
</tr>
</thead>
<tbody>
<tr>
<td>4/6/2011</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**France**

- Lourdes Sports: $53,370.14
- Sports Centre-ville: $65,005.00
- Sud Cycles: $68,000.50
- Sports Alsace: $52,787.50
- Paris Mountain Sports: $300,000.00

**Total for France:** $539,163.14

**USA**

- Tek Bikes: $301,568.22
- Extreme Cycling: $69,819.10
- Uni-Cycle: $52,428.13
- Whistler Rentals: $68,000.00
- Alley Cat Cycles: $298,356.22
- Hooked on Helmets: $52,963.82
- Trail Blazer's Place: $123,658.46
- Sporting Wheels Inc.: $85,642.56
- Psycho-Cycle: $52,809.11

**Total for USA:** $1,105,245.62

**Grand Total:** $1,644,408.76
Grouping window: group your data based on one or more fields e.g. group the records by country

Select the field(s) to group by from the report fields (displayed on the report) or from the list of fields in the view.
Summaries window: to show group totals, maximum and minimum values, record counts, most frequent numbers and some statistical calculations

To add summaries:

1. Select the field and add it to the Summarized Fields panel on the right side.
2. From the bottom of the right panel, select the type of summary.
advertisement

- **Group Sorting** window: to sort the data by summarized totals and display the top or bottom 5 groups.
  
e.g. show the top 5 last year’s sales by country

To Select the top 5 or bottom 5

1. Select the field **Group** that will be sorted
2. Select the option: **Top 5 groups** or **Bottom 5 groups**
3. Select the field with summarized totals.
Chart window: add a chart to your report

1. Select the kind of chart
2. Enter a Chart title
3. Select a field in the On change of dropdown list
4. Select the summary field.
If you do not need all the records, you can select only those useful to create the report

Example 1: create a report on customer ID 123456

1. Select the field
   - Customer ID

2. Choose the selection criterion
   - Is equal to

3. Enter the value
   - 123456
Example 2: create a report of stores who sold less than $10,000

1. Select the field
   Sales amount

2. Choose the selection criterion
   Is less than

3. Enter the value
   $10,000
To select the records:

1. Add the fields needed for the selection of records in the right panel
2. Select the operator from the dropdown list at the bottom
3. Enter a value (criteria)
Template window: select a report template from the list

- Click the Browse button to use a previous report for a template
Generate the report

• Click on **Finish** button

• It takes a moment for the system to display the report.

• To modify the report: use the commands from the toolbar or menu bar
Exercise 1
Create a simple report

Scenario

Create a report with a list of customers from three countries: Belgium, France and USA. Show in the report, their names and their address. Group them by country.

1. Open the report wizard

2. Double-click the database under **My Connections**

   G:\Banner\user\share\Everyone\Crystal reports\Crystal Report Samples\en\Databases\xtreme.mdb
Crystal Reports

The layout

- The Menu bar
- The Standard toolbar
- The Formatting toolbar
- The Insert toolbar
- The Expert toolbar
- The Navigation toolbar
Crystal Reports
The layout

- Each report created during the same session has its own tab

The tabs:
- **Start Page** tab: goes to the home page
- **The Report** tab: shows the report’s name
- Two sub-tabs:
  - **Preview**: displays the report and the result of your choices
  - **Design**: to format the report, add text, add more fields
Design tab

- The report is made of various sections to make the editing and the formatting easy.

- **Report Header** appears at the beginning of report (e.g. the title)
- **Page Header** contains your column headings, on each page
- **Group Header** contains the name of your group, if you created group(s)
- **Details** contains all the data retrieved (the records)
- **Group Footer** contains the subtotals for each group
- **Page Footer** displays items to appear at the bottom of each page (e.g. page numbers, file path, etc.)
- **Report Footer** contains information that you wish to display at the end of the report (e.g. grand total for all records retrieved).
Stores information about the report.

This information can be picked by Special Fields (e.g. the title and the author of the report) to add to your report.
Format the report

- Move the fields by dragging them horizontally or vertically
- Resize the fields: click the field and use the field’s resizing handles
- Change the fonts, the colors, the style with the **Formatting** toolbar
- Delete a field: right-click the field and click **Delete**
- Modify a section’s size: drag the margin indicator displayed under the Design tab
- Hide a section: right-click on a section name and click Hide
Exercise 2

Format the report created in Exercise 1

Scenario

After previewing the report, you realized that the name of the country is repeated too many times. You want to remove it when it is not necessary. You also want to do some formatting: i.e. make the field headings appear in bold, add a background colour, and resize / move some fields.
Modifying the report
Add a field

After creating the report with the Standard Report Creation wizard, you can still add fields.

To add a new field, be in Design view. Move around or resize field width to create enough space on your report and follow these steps:

1. Click View > Field Explorer or click on the Field Explorer icon.
2. Click ‘+’ of Database Fields.
3. Locate the view and select the field to add.
4. Drag the field to the appropriate section of the report (Details section for data).
Modifying the report
Add a title

- Add a title to the report using Special Fields

*Note:* only if you have entered a title in the **Document Properties** under **File > Summary Info**

---

**To add a title to your report:**

1. Click **View > Field Explorer** or click on the **Field Explorer** icon

2. From the **Special Fields**, drag the **Report Title** to the appropriate section in your report
Sort your report: display the records in a specific order (e.g. last names in alphabetical order)

To sort data:

1. Click on the Record Sort Expert icon
2. Add the field that you want to sort to the right panel
3. Select the option Ascending or Descending
Modifying the report
Add text

- To add text to your report, insert a text object
- A text object can be moved, resized and formatted.
- To merge two text fields, drag the two fields in the text box (e.g. Last name, First name)

To add text:

1. Click on the **Insert Text Object** icon
2. Draw the box in the section of your choice with your mouse
3. Type the text inside the box
Exercise 3
Add text and fields to a report
Sort the records

Scenario

• Save the report
• Add a title to the report created in exercise 1.
• Display the file name and path in the page footer.
• Sort the names of the customers in alphabetical order.
• Add another field called **Region** to the report.
10 minute break
To change your selection of records:

1. Click on the **Select Expert** icon
2. View your criteria under each tab. There is one tab per field used for your selection.
3. Change your operator and the values
4. To add a new field and add a new criterion for that field, click on **New**
5. Modify the formula if needed
6. For more advanced editing, click **Formula Editor** button

Modify the criteria of your select statement to narrow or increase the number of records, for example:
When you select records, Crystal Reports applies a formula, which contains:

**field names, operators & values**

```
{top_customers.country} = “Canada”

or

{top_customers.country} ≡ “USA”
```
Modifying the Report
Boolean logic

• The Select statement is very important.

• When you use the Select Expert, Crystal report puts an “and” by default between the selection criteria fields.
  
  e.g. {Client ID} = “12345” and {Country} = “Canada”

• There is a big difference between AND and OR
  – AND limits your selection
  – OR increases your selection
Modifying the Report

Boolean logic

- Example of the difference between “and” and “or”

  - Clients who bought
    
    \{item description\} = “gloves” and
    
    \{item description\} = “shoes” and
    
    \{item description\} = “accessories”

  - Clients who bought

    \{item description\} = “gloves” or
    
    \{item description\} = “shoes” or
    
    \{item description\} = “accessories”
Modifying the Report

Boolean logic

Use parentheses when you mix AND and OR

Example:

\[
\{(\text{country} = \text{“Canada”} \ \text{or} \ \text{country} = \text{“U.S.”}) \ \text{and} \ \{(\text{item description} = \text{“gloves”} \ \text{or} \ \text{item description} = \text{“shoes”})\}\}
\]
Modifying the Report

Group the data

- Group the records based on a field or change the group already created with the Standard Report Wizard

1. Click on the Group Expert icon
2. Add the fields to group by to the right panel
3. Click on Options and select either
   - ascending order
   - descending order
   - specified order
   - original order
Types of summaries that you can add in your report:

- **Count** the total number of values or the number of values in a group
- **Distinct Count** the total number of values that are unique
- Calculate the **sum** of values
- Identify the **maximum or minimum value**
- Identify the **Nth largest** or **smallest** values
- Calculate the **average** value for a group or the whole report
Modifying the Report
Add Summaries

Use Insert Summary icon to add data summaries in your report.

To add summaries (e.g. totals):

1. Click on the **Insert Summary** icon
2. Select the field
3. Select the type of summary (e.g. Sum)
4. Select the summary location: a group or grand total
To do a top N analysis:

1. Click on the **Group Sort Expert** icon
2. Select the group sort Type from the list
3. Give a value to **N**
4. Select the **field** to be used
5. Decide whether to include or exclude other records that doesn’t match the sort type.

- Order data based on summaries (e.g. subtotals)
- Show in the report only the top N or bottom N groups considering the subtotals for the group.
  - e.g. the report will show the 5 stores with the highest sales
Exercise 4

Once a report is created: change the selection of records, edit the formula, group the records, add summaries

Scenario

- You want a report showing a list of contact persons who are from France, Mexico and USA or who sold for more than $100,000 from any other country. You use the Standard Report Creation Wizard. Once you preview the reports, you realize that the records selection should be modified, the contacts should be grouped by country and total of sales added for each country and for all the contacts. You also want to see at the top of the report, the 5 top countries who sold the most.
Exercise 4

Once a report is created: change the selection of records, edit the formula, group the records, add summaries

- **Records:**
  - Country: France or Mexico or USA
  - OR
    - Sales > $100,000
- **Group:** country
- **Summary:** total sales by country
- **Sort:** top 3 countries for their sales at the top of the report
Modifying the Report
Formula field

Creating a new formula field

- At times, you may want to create a new field (a formula field) using values from other fields and arithmetic operators.

\[
\text{Days Off} = \{\text{vacation days}\} + \{\text{personal days}\}
\]

\[
\% \text{ of items Sold} = (\{\text{items sold}\}/\{\text{items in stock}\}) \times 100\% 
\]
Modifying the report
Add a formula field

1. Create the formula field using the Formula Workshop

2. Insert the formula field in the report using Field Explorer and dragging the field to the Details section of the report
To create a formula:

1. Open the Formula Workshop
2. Select Formula Fields from the left panel
3. Click on New icon or right-click Formula Fields and click New
4. Enter a name for the new Formula.
5. Click OK

Create the formula field using the Formula Workshop
6. Create the formula using fields from the field list and operators from the operators list.
   • Double-click on each field and operator (or enter it manually) to add it to the formula
   • Check for any syntax errors, by clicking on the Check icon or press Alt+C
7. Click Save and Close
Exercise 5
Create and add a formula field to the report.

Scenario

Create a formula to calculate the average time it takes to deliver a product to a customer using data from year 2005
Export a dataset

To export the report to an Excel file:

1. Select your view, fields and records
2. Sort and group them if necessary
3. Preview the report to check the data
4. Go to **File** > **Export** > **Export Report**
5. Select a format from the ‘Format’ list:
   - to export to Excel and keep the formatting, select Microsoft Excel (97-2003) and click **OK**.
6. Specify a location to save the file
7. Enter a name for the file
8. Click Save.
1. Select **Mailing Label Report Wizard** from the Start Page or click **File > New > Mailing Label Report**

2. Select the appropriate fields from the database to create a mailing label.

3. The wizard will guide you through the steps (including to select the right mailing label type (Avery, 3M etc.))
Exercise 6
Create mailing labels

Scenario

Create a mailing list of all customers from USA with details of a product discount.
What’s next?

• Other courses:
  – **FIS 351** – Crystal Reports for Finance Users – Level I
  – **FIS 352** – Crystal Reports for Financial Services Staff – Level II
  – **SIS 317** – Querying the Student Datawarehouse

  • **Prerequisite**: access to the Student Datawarehouse
  • Request the access at least a week before
  • Form to request the access:
    

  – Register through Minerva
    
    Employee > IST Customer services (ICS) menu
Documentation

• Financial services documentation:
  Knowledge base: http://kb.mcgill.ca/fskb/
  Click Browse > Working with Crystal Reports

• Enrolment Services documentation
  http://www.mcgill.ca/es/dwh

• IT Knowledge Base
  http://www.mcgill.ca/it
  “Data Warehouse Service”: article #1434
Support

For Financial Services:

• To request or modify a new report, go to http://www.mcgill.ca/financialservices/reporting/requestform

• If you want to create a brand new report (not recommended): contact the finance helpdesk
  – To verify if the report exist
  – To verify the data of your new report once it is created
  – To give you more information about the database
Support

• Contact IT services for issues connecting to the database
  • By phone: 398-3398
  • By email: ITsupport@mcgill.ca

• Contact the Finance Help Desk for Finance reports
  • By phone: 398-3463
  • By email: Fishelp.acct@mcgill.ca

• Contact for SIS reports
  • By email: sisreport@mcgill.ca
Your opinion counts!

Answer just five questions- one minute of your time!

• Please complete the **IT Course Evaluation** Form
• In Minerva at:

  Employee Menu > IT Customer Services (ICS) Menu > Training Evaluations.

Thank you! 😊